Aus der Tiefe
   


About
Aus der Tiefe, Meldungen des Rechenzentrums in der Cauerstrasse 11

Matthias Bauer und Martin Bayer problems@math.fau.de

Subscribe
Subscribe to a syndicated feed of my weblog, brought to you by the wonders of RSS.

Flavours
There's more than one way to view this weblog; try these flavours on for size.

  • index
  • circa 1993
  • RSS
  • Links

  • Shoestring FoundationMiscellaneous byproducts

  •        
    Thu, 23 May 2019

    Thursday, May 23, 2019 11:48:09


    	Umgekehrtes Problem zu letzter Woche: auf einem Server versucht 'apt-get dist-upgrade' unser meta-Packet fuer Arbeitsplaetze
    	  zu installieren. Das Ding hat laut dpkg-query keine Reverse-Dependencies, d.h. es gibt kein Packet unter der Sonne, das
    	  zum Upgraden dieses Packet braeuchte. Und es gibt keine Puppet-Rule, die es installieren soll, und es gibt keinen
    	  Eintrag in den diversen apt-spezifischen Directories, dass es installiert werden sollte. Vollkommen unklar, woher
    	  der Wille zum Install kommt. Explizit verbieten kann man das durch eine Datei in /etc/apt/preferences.d/ mit
    	  dem Inhalt
    		Package: $das_unerwuenschte_Packet_der_Wahl
    		Pin: release n=xenial*
    		Pin-Priority: -3
    	  (Negative Prioritaet verhindert Installation. (Prioritaet == 0 erzeugt laut manpage undefined behaviour))
    
    

    [/bauerm] permanent link